import Foundation
let pattern = ##"^(#'YOUR_ANSWER.*)(?:\R(?!\h*#'END_ANSWER$).*)*(\R\h*#'END_ANSWER)$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
#'YOUR_ANSWER
As_samp2 = 36
As_samp3 = 38
#'END_ANSWER
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\nspace for answer$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)