# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.{3})(-| )?(.{3}),*$/$1-$3/gm;t' <<< "234-345
543879
654 899,,"