// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.{3})(-| )?(.{3}),*$").unwrap();
let string = "234-345
543879
654 899,,";
let substitution = "$1-$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}