#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.{3})(-| )?(.{3}),*$"
Local $sString = "234-345" & @CRLF & _
"543879" & @CRLF & _
"654 899,,"
Local $sSubst = "$1-$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)