$re = '/^(.{3})(-| )?(.{3}),*$/m';
$str = '234-345
543879
654 899,,';
$subst = "$1-$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;