const regex = /^(.{3})(-| )?(.{3}),*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.{3})(-| )?(.{3}),*$', 'gm')
const str = `234-345
543879
654 899,,`;
const subst = `$1-$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);