package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.{3})(-| )?(.{3}),*$`)
var str = `234-345
543879
654 899,,`
var substitution = "$1-$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}