# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+-)(\w)(\w+)/\U$1\U$2\L$3/gm;t' <<< "us-east-1 or uk-west-5"