$re = '/(\w+-)(\w)(\w+)/m';
$str = 'us-east-1 or uk-west-5';
$subst = "\U$1\U$2\L$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;