using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+-)(\w)(\w+)";
string substitution = @"\U$1\U$2\L$3";
string input = @"us-east-1 or uk-west-5";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}