// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\w+-)(\w)(\w+)").unwrap();
let string = "us-east-1 or uk-west-5";
let substitution = "\\U$1\\U$2\\L$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}