import Foundation
let pattern = #"(\w+-)(\w)(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"us-east-1 or uk-west-5"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\U$1\U$2\L$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)