re = /(\w+-)(\w)(\w+)/m
str = 'us-east-1 or uk-west-5'
subst = '\\U$1\\U$2\\L$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result