#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\w+-)(\w)(\w+)"
Local $sString = "us-east-1 or uk-west-5"
Local $sSubst = "\U$1\U$2\L$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)