using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-zA-Z\.-]{2,}";
string input = @"example.com=120.0.0.0
ben.example.com=120.0.0.0
+ben.example=120.0.0.0
+ben-example.com.np=120.0.0.0
ben=120.0.0.0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}