import re
regex = re.compile(r"[a-zA-Z\.-]{2,}", flags=re.MULTILINE)
test_str = ("example.com=120.0.0.0\n"
"ben.example.com=120.0.0.0\n"
"+ben.example=120.0.0.0\n"
"+ben-example.com.np=120.0.0.0\n"
"ben=120.0.0.0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")