const regex = new RegExp('[a-zA-Z\\.-]{2,}', 'gm')
const str = `example.com=120.0.0.0
ben.example.com=120.0.0.0
+ben.example=120.0.0.0
+ben-example.com.np=120.0.0.0
ben=120.0.0.0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}