re = /[a-zA-Z\.-]{2,}/m
str = 'example.com=120.0.0.0
ben.example.com=120.0.0.0
+ben.example=120.0.0.0
+ben-example.com.np=120.0.0.0
ben=120.0.0.0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end