$re = '/[a-zA-Z\.-]{2,}/m';
$str = 'example.com=120.0.0.0
ben.example.com=120.0.0.0
+ben.example=120.0.0.0
+ben-example.com.np=120.0.0.0
ben=120.0.0.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);