import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z\\.-]{2,}";
final String string = "example.com=120.0.0.0\n"
+ "ben.example.com=120.0.0.0\n"
+ "+ben.example=120.0.0.0\n"
+ "+ben-example.com.np=120.0.0.0\n"
+ "ben=120.0.0.0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}