# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\\/|^)[^\\/\n]*\\/(?=[^\\/\n]+$)//gm;t' <<< "/Volumes/Server/Order/138000/138625 - Customer Name/Production/138625_1_67x14.2_x2.pdf
/Volumes/Server/Order/138000/138625 - Customer Name/138625_1_67x14.2_x2.pdf
/Volumes/Server/Order/138000/138625_1_67x14.2_x2.pdf
/Volumes/Server/Order/138625_1_67x14.2_x2.pdf
/Volumes/Server/138625_1_67x14.2_x2.pdf
/Volumes/138625_1_67x14.2_x2.pdf
/138625_1_67x14.2_x2.pdf"