# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\/|^)[^\/\n]*\/(?=[^\/\n]+$)"
test_str = ("/Volumes/Server/Order/138000/138625 - Customer Name/Production/138625_1_67x14.2_x2.pdf\n\n"
"/Volumes/Server/Order/138000/138625 - Customer Name/138625_1_67x14.2_x2.pdf\n\n"
"/Volumes/Server/Order/138000/138625_1_67x14.2_x2.pdf\n\n"
"/Volumes/Server/Order/138625_1_67x14.2_x2.pdf\n\n"
"/Volumes/Server/138625_1_67x14.2_x2.pdf\n\n"
"/Volumes/138625_1_67x14.2_x2.pdf\n\n"
"/138625_1_67x14.2_x2.pdf")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.