const regex = /(?<=\/|^)[^\/\n]*\/(?=[^\/\n]+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\\/|^)[^\\\/\\n]*\\\/(?=[^\\\/\\n]+$)', 'gm')
const str = `/Volumes/Server/Order/138000/138625 - Customer Name/Production/138625_1_67x14.2_x2.pdf
/Volumes/Server/Order/138000/138625 - Customer Name/138625_1_67x14.2_x2.pdf
/Volumes/Server/Order/138000/138625_1_67x14.2_x2.pdf
/Volumes/Server/Order/138625_1_67x14.2_x2.pdf
/Volumes/Server/138625_1_67x14.2_x2.pdf
/Volumes/138625_1_67x14.2_x2.pdf
/138625_1_67x14.2_x2.pdf`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);