use strict;
my $str = '/Volumes/Server/Order/138000/138625 - Customer Name/Production/138625_1_67x14.2_x2.pdf
/Volumes/Server/Order/138000/138625 - Customer Name/138625_1_67x14.2_x2.pdf
/Volumes/Server/Order/138000/138625_1_67x14.2_x2.pdf
/Volumes/Server/Order/138625_1_67x14.2_x2.pdf
/Volumes/Server/138625_1_67x14.2_x2.pdf
/Volumes/138625_1_67x14.2_x2.pdf
/138625_1_67x14.2_x2.pdf';
my $regex = qr/(?<=\/|^)[^\/\n]*\/(?=[^\/\n]+$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";