import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\/|^)[^\\/\\n]*\\/(?=[^\\/\\n]+$)";
final String string = "/Volumes/Server/Order/138000/138625 - Customer Name/Production/138625_1_67x14.2_x2.pdf\n\n"
+ "/Volumes/Server/Order/138000/138625 - Customer Name/138625_1_67x14.2_x2.pdf\n\n"
+ "/Volumes/Server/Order/138000/138625_1_67x14.2_x2.pdf\n\n"
+ "/Volumes/Server/Order/138625_1_67x14.2_x2.pdf\n\n"
+ "/Volumes/Server/138625_1_67x14.2_x2.pdf\n\n"
+ "/Volumes/138625_1_67x14.2_x2.pdf\n\n"
+ "/138625_1_67x14.2_x2.pdf";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}