re = /(?<=\/|^)[^\/\n]*\/(?=[^\/\n]+$)/m
str = '/Volumes/Server/Order/138000/138625 - Customer Name/Production/138625_1_67x14.2_x2.pdf
/Volumes/Server/Order/138000/138625 - Customer Name/138625_1_67x14.2_x2.pdf
/Volumes/Server/Order/138000/138625_1_67x14.2_x2.pdf
/Volumes/Server/Order/138625_1_67x14.2_x2.pdf
/Volumes/Server/138625_1_67x14.2_x2.pdf
/Volumes/138625_1_67x14.2_x2.pdf
/138625_1_67x14.2_x2.pdf'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result