# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<img.*?)(src=")(.*?\\/)([^\\/]*")(.*?)(alt=")(.*?")([^>]*>)/src="" data-path="\1" data-img="\2"/;t' <<< "<img class=\"alignnone size-medium wp-image-18\" src=\"http://localhost/wp-content/uploads/2015/02/300x149-jquerymobile.jpg\" alt=\"\" width=\"300\" height=\"149\">"