import re
regex = re.compile(r"(<img.*?)(src=\")(.*?\/)([^\/]*\")(.*?)(alt=\")(.*?\")([^>]*>)")
test_str = "<img class=\"alignnone size-medium wp-image-18\" src=\"http://localhost/wp-content/uploads/2015/02/300x149-jquerymobile.jpg\" alt=\"\" width=\"300\" height=\"149\">"
subst = "src=\"\" data-path=\"\\1\" data-img=\"\\2\""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)