import Foundation
let pattern = #"(<img.*?)(src=")(.*?\/)([^\/]*")(.*?)(alt=")(.*?")([^>]*>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<img class="alignnone size-medium wp-image-18" src="http://localhost/wp-content/uploads/2015/02/300x149-jquerymobile.jpg" alt="" width="300" height="149">"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"src="" data-path="\1" data-img="\2""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}