using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<img.*?)(src="")(.*?\/)([^\/]*"")(.*?)(alt="")(.*?"")([^>]*>)";
string substitution = @"src="" data-path=""\1"" data-img=""\2""";
string input = @"<img class=""alignnone size-medium wp-image-18"" src=""http://localhost/wp-content/uploads/2015/02/300x149-jquerymobile.jpg"" alt="" width=""300"" height=""149"">";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}