use strict;
my $str = '<img class="alignnone size-medium wp-image-18" src="http://localhost/wp-content/uploads/2015/02/300x149-jquerymobile.jpg" alt="" width="300" height="149">';
my $regex = qr/(<img.*?)(src=")(.*?\/)([^\/]*")(.*?)(alt=")(.*?")([^>]*>)/p;
my $subst = 'src="" data-path="\\1" data-img="\\2"';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";