// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(<img.*?)(src=")(.*?\/)([^\/]*")(.*?)(alt=")(.*?")([^>]*>)"#).unwrap();
let string = "<img class=\"alignnone size-medium wp-image-18\" src=\"http://localhost/wp-content/uploads/2015/02/300x149-jquerymobile.jpg\" alt=\"\" width=\"300\" height=\"149\">";
let substitution = "src=\"\" data-path=\"\\1\" data-img=\"\\2\"";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}