const regex = /(<img.*?)(src=")(.*?\/)([^\/]*")(.*?)(alt=")(.*?")([^>]*>)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<img.*?)(src=")(.*?\\\/)([^\\\/]*")(.*?)(alt=")(.*?")([^>]*>)', '')
const str = `<img class="alignnone size-medium wp-image-18" src="http://localhost/wp-content/uploads/2015/02/300x149-jquerymobile.jpg" alt="" width="300" height="149">`;
const subst = `src="" data-path="\1" data-img="\2"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);