#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\S+)(\S*?)\s+?(\S*?(\1)\S*?)$"
Local $sString = "ABCD 19475ABCD_97jdhgbl" & @CRLF & _
"ABCD 19475ABC_97jdhgbl" & @CRLF & _
"CDEF 87437862AB83742kh" & @CRLF & _
"が増える 値段がが増える" & @CRLF & _
"上げる 彼は荷物をあみだなに上げた。" & @CRLF & _
"ABCDABCD ABCD" & @CRLF & _
"務める ああうるさい務めすは苦手で"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")