import re
regex = re.compile(r"^(\S+)(\S*?)\s+?(\S*?(\1)\S*?)$", flags=re.MULTILINE)
test_str = ("ABCD 19475ABCD_97jdhgbl\n"
"ABCD 19475ABC_97jdhgbl\n"
"CDEF 87437862AB83742kh\n"
"が増える 値段がが増える\n"
"上げる 彼は荷物をあみだなに上げた。\n"
"ABCDABCD ABCD\n"
"務める ああうるさい務めすは苦手で")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")