use strict;
my $str = 'ABCD 19475ABCD_97jdhgbl
ABCD 19475ABC_97jdhgbl
CDEF 87437862AB83742kh
が増える 値段がが増える
上げる 彼は荷物をあみだなに上げた。
ABCDABCD ABCD
務める ああうるさい務めすは苦手で';
my $regex = qr/^(\S+)(\S*?)\s+?(\S*?(\1)\S*?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}