$re = '/^(\S+)(\S*?)\s+?(\S*?(\1)\S*?)$/m';
$str = 'ABCD 19475ABCD_97jdhgbl
ABCD 19475ABC_97jdhgbl
CDEF 87437862AB83742kh
が増える 値段がが増える
上げる 彼は荷物をあみだなに上げた。
ABCDABCD ABCD
務める ああうるさい務めすは苦手で';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);