import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\S+)(\\S*?)\\s+?(\\S*?(\\1)\\S*?)$";
final String string = "ABCD 19475ABCD_97jdhgbl\n"
+ "ABCD 19475ABC_97jdhgbl\n"
+ "CDEF 87437862AB83742kh\n"
+ "が増える 値段がが増える\n"
+ "上げる 彼は荷物をあみだなに上げた。\n"
+ "ABCDABCD ABCD\n"
+ "務める ああうるさい務めすは苦手で";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}