using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\S+)(\S*?)\s+?(\S*?(\1)\S*?)$";
string input = @"ABCD 19475ABCD_97jdhgbl
ABCD 19475ABC_97jdhgbl
CDEF 87437862AB83742kh
が増える 値段がが増える
上げる 彼は荷物をあみだなに上げた。
ABCDABCD ABCD
務める ああうるさい務めすは苦手で";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}