# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((www\.|(http|https|ftp|news|file)+\:\\/\\/)?[_.a-zA-Z0-9-]+\.[a-zA-Z0-9\\/_:@=.+?,##%&~-]*[^.|\'|\#|\(|?|,| |>|<|;|\)]*)//gm;t' <<< "bla1 bla2 http://www.peckale.com/#!contact/c11m6 bla3"