re = /((www\.|(http|https|ftp|news|file)+\:\/\/)?[_.a-zA-Z0-9-]+\.[a-zA-Z0-9\/_:@=.+?,##%&~-]*[^.|\'|\#|\(|?|,| |>|<|;|\)]*)/m
str = 'bla1 bla2 http://www.peckale.com/#!contact/c11m6 bla3'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result