const regex = /((www\.|(http|https|ftp|news|file)+\:\/\/)?[_.a-zA-Z0-9-]+\.[a-zA-Z0-9\/_:@=.+?,##%&~-]*[^.|\'|\#|\(|?|,| |>|<|;|\)]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((www\\.|(http|https|ftp|news|file)+\\:\\\/\\\/)?[_.a-zA-Z0-9-]+\\.[a-zA-Z0-9\\\/_:@=.+?,##%&~-]*[^.|\\\'|\\#|\\(|?|,| |>|<|;|\\)]*)', 'gm')
const str = `bla1 bla2 http://www.peckale.com/#!contact/c11m6 bla3`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);