using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((www\.|(http|https|ftp|news|file)+\:\/\/)?[_.a-zA-Z0-9-]+\.[a-zA-Z0-9\/_:@=.+?,##%&~-]*[^.|\'|\#|\(|?|,| |>|<|;|\)]*)";
string substitution = @"";
string input = @"bla1 bla2 http://www.peckale.com/#!contact/c11m6 bla3";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}