$re = '/((www\.|(http|https|ftp|news|file)+\:\/\/)?[_.a-zA-Z0-9-]+\.[a-zA-Z0-9\/_:@=.+?,##%&~-]*[^.|\'|\#|\(|?|,| |>|<|;|\)]*)/m';
$str = 'bla1 bla2 http://www.peckale.com/#!contact/c11m6 bla3';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;