import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((www\\.|(http|https|ftp|news|file)+\\:\\/\\/)?[_.a-zA-Z0-9-]+\\.[a-zA-Z0-9\\/_:@=.+?,##%&~-]*[^.|\\'|\\#|\\(|?|,| |>|<|;|\\)]*)";
final String string = "bla1 bla2 http://www.peckale.com/#!contact/c11m6 bla3";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}