#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^body|\sbody([\s*|\{|:])"
Local $sString = "body .myclass{" & @CRLF & _
" font: heavy;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"body#p-5 #main .box h2 {" & @CRLF & _
" font-size: 21.85px" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
"body.myclass .hello {" & @CRLF & _
" font-size: 10px;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"body .myclass{" & @CRLF & _
" font: heavy;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"body#p-5 #main .box h2 {" & @CRLF & _
" font-size: 21.85px" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" body.myclass .hello {" & @CRLF & _
" font-size: 10px;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
" body .myclass {" & @CRLF & _
" font: heavy;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")