re = /^body|\sbody([\s*|\{|:])/
str = 'body .myclass{
font: heavy;
}
body#p-5 #main .box h2 {
font-size: 21.85px
}
body.myclass .hello {
font-size: 10px;
}
body .myclass{
font: heavy;
}
body#p-5 #main .box h2 {
font-size: 21.85px
}
body.myclass .hello {
font-size: 10px;
}
body .myclass {
font: heavy;
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end