import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^body|\\sbody([\\s*|\\{|:])";
final String string = "body .myclass{\n"
+ " font: heavy;\n"
+ "}\n\n"
+ "body#p-5 #main .box h2 {\n"
+ " font-size: 21.85px\n"
+ " }\n\n"
+ "body.myclass .hello {\n"
+ " font-size: 10px;\n"
+ "}\n\n"
+ "body .myclass{\n"
+ " font: heavy;\n"
+ "}\n\n"
+ "body#p-5 #main .box h2 {\n"
+ " font-size: 21.85px\n"
+ " }\n\n"
+ " body.myclass .hello {\n"
+ " font-size: 10px;\n"
+ "}\n\n"
+ " body .myclass {\n"
+ " font: heavy;\n"
+ "}\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}