const regex = /^body|\sbody([\s*|\{|:])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^body|\\sbody([\\s*|\\{|:])', 'g')
const str = `body .myclass{
font: heavy;
}
body#p-5 #main .box h2 {
font-size: 21.85px
}
body.myclass .hello {
font-size: 10px;
}
body .myclass{
font: heavy;
}
body#p-5 #main .box h2 {
font-size: 21.85px
}
body.myclass .hello {
font-size: 10px;
}
body .myclass {
font: heavy;
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}