import re
regex = re.compile(r"^body|\sbody([\s*|\{|:])")
test_str = ("body .myclass{\n"
" font: heavy;\n"
"}\n\n"
"body#p-5 #main .box h2 {\n"
" font-size: 21.85px\n"
" }\n\n"
"body.myclass .hello {\n"
" font-size: 10px;\n"
"}\n\n"
"body .myclass{\n"
" font: heavy;\n"
"}\n\n"
"body#p-5 #main .box h2 {\n"
" font-size: 21.85px\n"
" }\n\n"
" body.myclass .hello {\n"
" font-size: 10px;\n"
"}\n\n"
" body .myclass {\n"
" font: heavy;\n"
"}\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")